Feature request #12304

improve message when role rights are not provided to public schema or the database is not spatially enabled

Added by Otto Dassau about 2 years ago.

Status:Open Start Date:03/03/2015
Priority:Normal Due date:
Assigned to:J├╝rgen Fischer % Done:

0%

Category:PostGIS Data Provider
Target version:Future Release - Nice to have
Platform: Resolution:
Platform version: Pull Request or Patch supplied:No
Status info: Tag:

Description

Hi,

I get following error in QGIS, when I try to connect with a NOSUPERUSER user to a postgis database:

ERROR: function postgis_version() does not exist at character 8
HINT: No function matches the given name and argument types. You might need to add explicit type casts.
STATEMENT: SELECT postgis_version()

The problem was, that I didn't grant create/usage rights for the user to the public schema. The same message seems to appear, if the database is not spatially enabled.

It would be helpful to improve the error message.

Regards
Otto

Also available in: Atom