Bug #5827

Printing issue

Added by Vivien Deparday almost 2 years ago. Updated 29 days ago.

Status:Open Start Date:06/19/2012
Priority:Normal Due date:
Assigned to:Pirmin Kalberer % Done:

0%

Category:-
Target version:-
Patch supplied:No Tag:

Description

I am trying to print a map (as an image) with the map composer. The map is composed of two vector layers (boundaries) displayed over tiles (Google Street or OpenStreetMap). It looks good in the main interface. It looks good in the map composer.
However, when printing the map as an image with the map composer, in the resulting exported image, the vector layers are no longer aligned properly with the tiles. It also looks like the tiles are at the wrong scale.

I have the same issue with Google Street and OpenStreetMap. I have not tested the other layers.

I am using:
OpenLayers Plugin v 0.92
QGIS 1.8.0 (from ubuntu-gis unstable)
Kubuntu 12.04

It sounds similar to this issue: http://hub.qgis.org/issues/4223

printing_issue.zip (519.6 kB) Otto Dassau, 11/06/2012 05:56 am

Screenshot_QGIS_google.jpg (751.5 kB) Christian Seemann, 02/15/2013 08:47 am

Test_google_a4_5000.pdf (213 kB) Christian Seemann, 02/15/2013 08:48 am

GenderMap.png - Result, png, location shifted (1.2 MB) Evelien Christiaanse, 03/20/2014 02:18 am

Screenshot1.png - Screenshot print composer (596.2 kB) Evelien Christiaanse, 03/20/2014 02:18 am

TransKLA.pdf - Result, pdf, scale changed (1 MB) Evelien Christiaanse, 03/20/2014 02:18 am

History

Updated by MRick - over 1 year ago

I have exactly the same problem with QGIS 1.8.0 under Mac OS X.

This bug is similar to the issue: http://hub.qgis.org/issues/4223 that has been fixed for 1.7.0, but it is coming back again with QGIS 1.8 …

Edit: it will not happen with all the layers : if I use a Google based layer, no problem, with an OSM based layer, the bug happens.

Updated by MRick - over 1 year ago

I made tests back to version 1.7 and everything works perfectly well.
Printing is even smoother with version 1.7 than version 1.8.

Updated by Pirmin Kalberer over 1 year ago

We can't reproduce these printing problems using QGIS 1.8 and master branch. Could you provide us a minimal dataset?

Updated by Otto Dassau over 1 year ago

Hi,

I just had the same problem with QGIS 1.8 under opensuse 12.2. I added a zip file. If you open the project "printing_issue.qgs" and the included DIN a3 map composition, all seems fine (see image screenshot.jpg). But when I export as PDF the google and vector layer extent don't fit anymore.

I use the openlayers plugin version 1.0.0

Regards
Otto

Updated by Otto Dassau over 1 year ago

  • Assigned to set to Pirmin Kalberer

Hi,

problems occur in both plugin versions 0.93 and 1.0.0 when I try to create DIN A3 maps. For DIN A4 it seems to work better.

Regards
Otto

Updated by Christian Seemann about 1 year ago

Hi everyone!

I got exactly the same Problem (see attached file):

QGIS 1.8.0 Lisboa
OpenLayers 1.1.0
Mac OS X 10.6.8 Snow Leopard

and Scale or Paper Size make no difference.
I noticed that it often works better "at the beginning" when I start QGIS but after a few (2 or 3) exports and after panning / working on the map int the main window, it starts "matching" the openlayers (google, osm...) a little slower with the vector layer.
...As if the memory was full! (8GB)
And suddenly the export shows the misalignment.

Anyway, I also would be very happy and grateful for some help!!
Thanks and regards

Chris

Updated by Christian Seemann about 1 year ago

...and this is the PDF result!

P.S. Sorry for posting the 2 Pics in different messages!

Updated by MRick - 7 months ago

Still not working after all this time and latest update of both OpenLayers and QGis …

Updated by Rowan Murphy 5 months ago

Am having exactly the same issue with:
  • QGIS 2.0.1
  • Open Layers 1.1.1

We do a lot of jobs on QGIS with many different vector/raster layers using Google aerial, Bing aerial underlay (Open Layers). The error is consistent across all projects with QGIS 2.X.X or higher.

On the same PC with the same map files/layers we do not experience this issue with:
  • QGIS 1.8.0
  • Open Layers latests stable release (from:http://openlayers.org/api/OpenLayers.js)

Is there anything that can be helped? Are we making a mistake in settings or do we have to remain with QGIS 1.8.0 until a fix is available?

Updated by Fridolin Haag 4 months ago

Still the same with Open Layers 1.1.2 (and QGIS 2.0.1).
Seems to be the same as: Bug #8824 , which was closed because: "The OpenLayers plugin does not support printing in the map composer."
It was suggested it has to do with the Map Composer failing to support "on the fly" projection, but reprojecting my layers to the basemap projection did not help.

Updated by Evelien Christiaanse 29 days ago

I have had the same issue recently while using 2.2.0. I made a vector layer and had it over an Open Street Maps layer, it looked fine when I made it in the print composer. However, as I exported it (pdf or png) the OSM layer was changed in scale or location.

Also available in: Atom PDF