Feature request #8709

Easier import of OSM data: bounding box

Added by Paolo Cavallini over 3 years ago. Updated about 3 years ago.

Status:Closed Start Date:09/27/2013
Priority:Normal Due date:
Assigned to:- % Done:

0%

Category:Vectors
Target version:Future Release - High Priority
Platform: Resolution:
Platform version: Pull Request or Patch supplied:No
Status info: Tag:

Description

I'm trying to import OSM data with the new importer, but I get a problem: the bounding box has to be specified in 4326. In the normal case, an user loads an OSM background in 3857, or his data in the respective SRS. In these case, we get an error:

Error downloading
http://overpass-api.de/api/interpreter?data=(node(5.41294e+06,1.18302e+06,5.41358e+06,1.18428e+06);%3C;);out;
- server replied: Bad Request

better always reproject the bounding box chosen by the user in 4326.


Related issues

duplicated by QGIS Application - Bug report #9103: Error downloading OSM data Closed 11/20/2013

Associated revisions

Revision 7becd761af05d3946e3c94017cffacf5ed72be4e
Added by Jürgen Fischer about 3 years ago

osm: transform extents to EPSG:4326 (fixes #8709)

History

Updated by Giovanni Manghi over 3 years ago

  • Target version set to Future Release - High Priority

Updated by iarla Kilbane-Dawe about 3 years ago

The source of this bus is correctly identified in the comments on the duplicate Bug #9103. The OSM overpass-api requires the co-ordinates in Decimal Degrees, while the feature sends the co-ordinates in the current co-ordinate system used in the project.

The bug can be eliminated in day-to-day use by switching the canvas co-ordinates to Decimal Degrees. The OSM layer then operates correctly.

Updated by Jürgen Fischer about 3 years ago

  • Status changed from Open to Closed

Also available in: Atom