Feature request #8884

Symbol too small in legend when map units are used

Added by Vincent Picavet over 3 years ago. Updated 8 months ago.

Status:Closed Start Date:04/10/2014
Priority:Normal Due date:
Assigned to:- % Done:

100%

Category:Map Legend
Target version:Future Release - Nice to have
Platform: Resolution:duplicate
Platform version: Pull Request or Patch supplied:No
Status info: Tag:

Description

When a symbol is defined with map units, it is sometimes shown in the legend at a very small scale, preventing to see the details.
If millimeters are used for symbol size, it is displayed in the legend at the right size.
A solution could be to used map units for the symbol display on the map, but fixed size for the symbol in the legend.

legenda.jpg (265.4 kB) michele zanolli, 07/01/2016 02:18 am


Subtasks

Bug report #10049: toc: point symbols not visible if in map unitsRejected

History

Updated by luca76 - almost 3 years ago

Confirmed.

If I use millimeters, the symbols are visible, but when I use map-units they are just too small to see (even with a EYEGLASS :-) )

Updated by michele zanolli 9 months ago

The problem still persists...
And in QGIS 2.14, if you use -->Categorized<-- style and map units for size of point/svg symbols, the size of the symbol in the layer legend is totally out of control (see attached image)

Updated by Reinhard Reiterer 9 months ago

See also:

#14850 'Layers Panel' - Symbol size depends on zoom level
#13779 symbols not correctly clipped in map legend

Updated by michele zanolli 9 months ago

Thanks, I think that we can mark this ticket as duplicated (even if older)

Updated by Nyall Dawson 8 months ago

  • Status changed from Open to Closed
  • Resolution set to duplicate

Also available in: Atom