Wish Lists

Are you missing some certain functionality in QGIS? Post your ideas and wishes for new Python plugins here:

Template

Title

  • Description:
  • Submitted by:

QGIS ColorBrewer, TypeBrewer

Import Layers from Project File

  • Description: Choose an existing .qgs file, it opens up a dialog showing the layers within, each with a check box. Check some or all, and they are loaded into the current project. Can also function as an 'include project' menu item that just gets all the layers. All the required API calls are worked out, just need to write the GUI.
  • Submitted by: Barry Rowlingson (geospacedman)
  • Barry has now implemented this in the "Import Layers" plugin!
    N.B. Also see the new "Layer>Embed layers and groups" feature, which dynamically references (rather than copying) layers from another project.

QGIS VRML Exporter (.WRL)

  • Description: Generate a simple .wrl file from raster (for texture) and DEM (for elevation) that may be used for instance with a 3D printer or even just a 3D viewer.
  • Submitted by: RiaanVanDenDool

Magnifier Panel

  • Description: Similar to the overview panel, except the opposite: have a panel displaying a zoomed in view of the map area around the mouse pointer.
  • Submitted by: Alister

Ovals for point layers with width, height and rotation based on attributes

  • Description: see this thread http://lists.osgeo.org/pipermail/qgis-developer/2011-June/014573.html It contains also pointers to some starting points in the python cookbook
  • Submitted by: Rduivenvoorde on behalf of uk52rob
    This is now implemented as the "ellipse marker" symbol layer type. It can also do a rectangle, crosshair or triangle!
    N.B. also see the rectangles, ovals and diamonds plugin, which can generate a new layer with rectangles, ovals or diamonds in it.

Genetic Landscapes GIS Toolbox (reusable python code)

Georeferencing rasters using corners coordinates of a vector grid ( reusable python code)

Heatmaps (reusable python code)

Implemented as a native C++ plugin.

Species connectivity and corridor network simulator (reusable python code)

Raster smoothing (reusable python code)

ClusterPy: Library of spatially constrained clustering algorithms (reusable python code)

  • Description: Analytical regionalization (also known as spatially constrained clustering) is a scientific way to decide how to group a large number of geographic areas or points into a smaller number of regions based on similarities in one or more variables (i.e., income, ethnicity, environmental condition, etc.) that the researcher believes are important for the topic at hand. Conventional conceptions of how areas should be grouped into regions may either not be relevant to the information one is trying to illustrate (i.e., using political regions to map air pollution) or may actually be designed in ways to bias aggregated results.
    http://www.rise-group.org/risem/clusterpy/index.html
  • Submitted by: Giovanni Manghi

Favourite Layers / Recent Layers

  • Description: Some people might find it useful to have a list of favourite layers which they can add to projects.
  • Implementation comments: One way to implement this would be to base it on the ImportProject plugin, which provides a lot of the functionality which would be necessary. In addition, what would be needed is (1) another button to launch it and automatically select the .qgs file which contains the favourite layers (i.e. skip the "Choose project file" dialogue), and (2) a way to select a layer in the current project to add to the favourite layers project. Ideally "Add from favourites" would be available in the Layer menu, and "Add to favourites" would be available in the Layer menu and in the Table of Contents right-click menu... but IIRC this would require the feature to be added to QGIS itself, rather than implemented as a plugin.

EDIT - a better way to implement this would be to have a list of recently opened layers (similar to "File>Recent Projects"), and to allow the user to "pin" favourite layers to this list, like in the Recent Documents menu in Microsoft Office 2007/2010. I'm not sure if it is possible to implement this in QT though.

  • Submitted by: Alister

N.B. in the browser dock widget in trunk there is the ability to add favourite <i>folders</i> (which look the same as top-level folders)
N.B. there is now a plugin to create a menu of layers from a project file. This is essentially a bookmarks menu.

Toggle visibility of selected layers

  • Description: It would be good to have a function to toggle the visibility of a selection of layers, or the layers in a selected group - not to turn them all on or turn them all off, but to turn on the layers that are currently off and turn off the layers that are currently on.
  • Implementation comments: Maybe this would be best implemented by reworking the "Map themes Builder" plugin, so that it works by selecting and applying a theme, which contains a list of layers which should be off and a list of layers which should be on.
  • Submitted by: Alister

Tool to select layers by clicking on them in the map canvas (rather than by clicking on them in the Table Of Contents / Map Legend)

Description: see Title.
  • Ctrl-Click could be used to add layers to the current selection, and Shift-Click (or something) could be used to remove layers from the current selection.
  • There could be different selection modes i.e. select by rectangle/polygon/freehand/radius
Example use cases:
  • There is a lot of information on the map and a user wants to quickly and clearly identify all the layers that have features in a certain location.
  • There are a lot of raster image tiles and the user wants to turn off those outside a particular area of interest. With this feature they can Ctrl-click to select all the files outside the area of interest, then toggle all those layers off at once (or remove them, or move them into a group). Instead of Ctrl-clicking to select the layers they don't want, they could alternatively select all the raster layers by shift-clicking in the Table of Contents, and then shift-click in the map window to unselect those in the area of interest.
  • The user wants to edit a vector object, but they don't instantly know which layer it is on. Normally they might use the interactive identify plugin to find out which layer it is on, then look for the layer in the Table of Contents, then click on the layer and enable editing. With this feature they could simply click on the object and the layer would be selected right away.
  • Submitted by: Alister

Export Map Composer layout to a yaml file compatible with Mapfish/GeoServer Print module)

Description: A button that exports a print composer layout to a yaml file that is usable in the print module of GeoServer and Mapfish.
Syntax is here: http://www.mapfish.org/doc/print/configuration.html.

Example use cases:
  • You create a layout in print composer, click a button that exports it to a yaml file, and you then use it directly in your print server, that is using the print module from geoserver/mapfish. This is a real time-saver and a great plugin to those that need to configure a print layout by hand!! measuring all objects' locations and dimensions!

*Submitted by: Duarte Carreira

Provider to open tables from Google spreadsheets (or similar service)

Description: see Title.

I believe this could be achieved using "Google Data APIs Python Client Library":
http://code.google.com/p/gdata-python-client/
This would be handy for smallish projects where multiple people will input or edit only the non-spatial data - it would eliminate the need for a real database.

  • Submitted by: Alister

Add and "R Free" geostatistic toolbox using HPGL

Description: see Title.

The los of RPY2 under Windows will make almost impossible to use R based plugins under Windows. There are good geostatistic libraries that do not depend on R (and so also on rpy2)

http://hpgl.aoizora.org/

  • Submitted by: Giovanni Manghi

Landform classification based on Topographic Position Index and Slope

Description: Landform classification algorithm based on:
  • Submitted by: Maning Sambale

Flash the selected feature(s)

Description: this idea is from ArcGIS, where you can right-click on a feature in the attribute table and choose "Flash". The feature flashes once in the map canvas. A giant (full screen) cross-hair also flashes to help you find it really easily.

Submitted by: Alister

python_genetics.pdf (236.8 kB) Giovanni Manghi, 08/12/2012 04:11 pm

1647.pdf (152.2 kB) Giovanni Manghi, 08/12/2012 04:11 pm

MGLPhase2p.py (10.7 kB) Giovanni Manghi, 08/12/2012 04:11 pm