Purpose

A lot of caves are surveyed to know their geographic position. On the computer, this survey is usually encoded in a dedicated software. Such a software is Toporobot / Limelight, which files are well known. The goal of this plug-in it to import those file in a GIS. The cave extend can then be viewed along with a terrain map or with geological information. Together with the geographic information, some information such as the cave name, gallery name, point number and the date of survey are recorded. If a digital elevation model is available and given, the depth of each points in the cave is computed.

The result, after assigning some colors depending on the depth, can look as follow (this are some real caves).
Example of a result, after assigning colors

Installation

If you haven't yet, install QGIS and open it.
Go in the menu Plugins > Manage and Install Plugins
Choose Get More , search for Toporobot, select the plugin and click Install Plugin.
For more installation about managing plugins, see http://www.qgis.org/en/docs/user_manual/plugins/plugins.htm

Usage

Open the menu Plugins > Import > Toporobot Importer.
This help is also available in the plug-in itself, accessible from the Help button.
Let see and describe the parameters, because that's the main thing.
If you don't have input files, you can use the example data.

Parameters

Toporobot .Text file

Icon of the Toporobot application Toporobot / Limelight is a software for managing cave surveys. It exports its data in a well known text file. This text file is expected to have a Mac-Roman encoding. Alternatively, use only latin characters. Known limitation: the left/right/top/bottom are expected to be in meter. Select the .Text file of the cave you want to import. It's of course mandatory for the import.

Toporobot .Coord file

As the plug-in doesn't compute the coordinates (and loop closing), it takes already computed coordinates. The coordinate are read from a coordinate file from Toporobot / Limelight. To generate this file, open your cave in Limelight and go to the menu File > List > Coordinates and make sure "Coordinates" is checked. In the plug-in, select the .Coord file of the cave you want to import. It's mandatory for the import.

Merge's mapping file

Importing hundreds of files would be boring. To avoid this, you can merge a lot of files so as to compute the coordinates and import the whole at once. By specifying the merge's mapping file (.csv file), the original file name and serie number can be retrieved as of before the merge. To merge, use the merge tool I created.

Layer with Elevation

You can select a raster layer which is a "digital elevation model" (DEM). If given, the plug-in will get elevation of the surface above each survey point and compute the vertical depth. The depth can then be used to nicely color the map and/or to know how deep to dig ;-).

Output shapefiles

Several sorts of shapefiles (.shp) can be generated. Choose at least one, otherwise you'll get no result. The texts and icons (and the knowledge of Toporobot) should make clear what will be generated.

Coordinate reference system

You can optionally define which coordinate reference system has the output file. It doesn't affect the input coordinates, it's only a metadata. Actually Toporobot was originally written for a metric coordinate reference system, namely the CH1903 / LV03. If at the import you are bothered by dialog asking you the coordinate reference system, either:
  • De-activate the "on-the-fly projection" of the project and/or of QGIS (preferences).
  • In the QGIS preference, define which is the default coordinate reference system if none is indicated
  • Define the coordinate reference system in the plug-in.

Output by

If the output file doesn't exist, don't matter. If the output file does already exist, choose if the existing shapes should be deleted or kept. Choose "Overriding" if you want to replace all the existing shapes with your new cave. Choose "Appending" if you want to add some (or one) more caves to the shapefile. By appending, don't mix the ouput types (points with lines for example).

Show the created layer(s)

Surely you would like to see straightaway your cave on the GIS. Then let this option checked. Don't worry if the shapefile is already shown. Un-check if you are only interested in generating a shapefile (.shp). If unchecked, already shown shapefiles won't disapear from the GIS.

Extra

Example data

Here are examples of the input data. It represents a real cave with fakes coordinates.
CaveMerged.Text
CaveMerged.Coord
CaveMerged-MergeInfo.csv

Form
Example of the suitable form

Purpose

The default QGIS view of the shape attributes is not so easy to read. The following form is much clearer and nicer, specific for the shapefiles generated by this plug-in. See on the right a screenshot of this form.

Installation

Download and save gallery_station.ui
Open the properties of a cave layer (with a double-clic or right-clic in the map legend)
Go to Fields
As Attribute editor layout (top right), choose Provide ui-file
As Edit interface (two fields bellow), select the gallery_station.ui you just saved.

Usage

Select the Identify Features tool, clic on a feature and, if you get a list of features, clic on View feature form (a pencil).

Merge

Purpose

This tool merges a lot of cave files so that they can be imported, exported, drawn or whatever at once. It merges hundreds of .Text files from Toporobot / Limelight in some seconds.

Installation and usage

Download and unpack Merge.zip
The detailed information are in the ReadMe file (LisMoi in french). Briefly, there are a perl script and a Mac drag-and-drop app.

Attachments

All the attachments of this page at once.

gallery_station.ui - Suitable form for the imported shapefiles (12.8 kB) Florian Hof, 02/15/2014 07:29 am

Merge.zip - Tool to merge .Text files (106.9 kB) Florian Hof, 02/15/2014 07:29 am

result_example.png - Example of a result, after assigning colors (27.5 kB) Florian Hof, 02/15/2014 07:29 am

toporobot.png - Icon of the Toporobot application (931 Bytes) Florian Hof, 02/15/2014 07:29 am

CaveMerged.Text - Example of a cave .Text file (5 kB) Florian Hof, 02/15/2014 07:29 am

CaveMerged.Coord - Example of a cave .Coord file (2.7 kB) Florian Hof, 02/15/2014 07:29 am

CaveMerged-MergeInfo.csv - Example of a cave merge file (475 Bytes) Florian Hof, 02/15/2014 07:29 am

gallery_station.png - Example of the suitable form (43 kB) Florian Hof, 02/19/2014 11:46 am